This repository has been archived on 2024-05-03. You can view files and clone it, but cannot push or open issues or pull requests.
treefmt/nix/treefmt.nix
Brian McGee 166a919fee
chore: remove flake-root input
No longer needed

Signed-off-by: Brian McGee <brian@bmcgee.ie>
2024-05-02 13:41:10 +01:00

71 lines
1.3 KiB
Nix

{inputs, ...}: {
imports = [
inputs.treefmt-nix.flakeModule
];
perSystem = {
config,
self',
...
}: {
treefmt.config = {
flakeCheck = true;
flakeFormatter = true;
projectRootFile = "flake.nix";
package = self'.packages.default;
programs = {
alejandra.enable = true;
deadnix.enable = true;
gofumpt.enable = true;
prettier.enable = true;
statix.enable = true;
};
settings.formatter = {
deadnix = {
pipeline = "nix";
priority = 1;
};
statix = {
pipeline = "nix";
priority = 2;
};
alejandra = {
pipeline = "nix";
priority = 3;
};
prettier = {
options = ["--tab-width" "4"];
includes = [
"*.css"
"*.html"
"*.js"
"*.json"
"*.jsx"
"*.md"
"*.mdx"
"*.scss"
"*.ts"
"*.yaml"
];
};
};
};
devshells.default = {
commands = [
{
category = "formatting";
name = "fmt";
help = "format the repo";
command = "nix fmt";
}
];
};
};
}