This repository has been archived on 2024-05-03. You can view files and clone it, but cannot push or open issues or pull requests.
treefmt/nix/formatters.nix
Brian McGee 40b76b74a0
feat: ensure deterministic application of formatters
Signed-off-by: Brian McGee <brian@bmcgee.ie>
2024-04-26 10:33:29 +01:00

33 lines
501 B
Nix

pkgs:
with pkgs; [
alejandra
elmPackages.elm-format
gotools
haskellPackages.cabal-fmt
haskellPackages.ormolu
mdsh
nixpkgs-fmt
nodePackages.prettier
python3.pkgs.black
rufo
rustfmt
shellcheck
shfmt
statix
deadnix
terraform
# util for unit testing
(pkgs.writeShellApplication {
name = "test-fmt";
text = ''
VALUE="$1"
shift
# append value to each file
for FILE in "$@"; do
echo "$VALUE" >> "$FILE"
done
'';
})
]